summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-13 16:25:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:40 -0400
commitf00552b1b17fe8840c70e4058241ea7149b4c236 (patch)
tree6195ad3b3f9540be46ffac7bcea6c54d2e9d6680 /gnu
parentac633a7acb449d75bce12560f4c3586a400eeb33 (diff)
gnu: Add ruby-flores.
* gnu/packages/ruby.scm (ruby-flores): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6093273bc8..07be7d7755 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3996,6 +3996,31 @@ fiber, and defaults to a shared thread-local state.")
(home-page "https://github.com/socketry/fiber-local")
(license license:expat)))
+(define-public ruby-flores
+ (package
+ (name "ruby-flores")
+ (version "0.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "flores" version))
+ (sha256
+ (base32
+ "0pd8gqgy67rp1baq5r7himl0r9jzv5kqlhdmqh8wngynv548w2ai"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec")))))))
+ (native-inputs (list ruby-rspec ruby-simplecov))
+ (synopsis "Fuzzing, randomization, and stress testing library")
+ (description "Flores is a fuzzing, randomization, and stress library to
+help tests uncover more bugs.")
+ (home-page "https://github.com/jordansissel/ruby-flores")
+ (license license:asl2.0)))
+
(define-public ruby-net-http-persistent
(package
(name "ruby-net-http-persistent")