summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-09 15:25:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:49 -0400
commitf05326d5c0c6f4b2d6f0b92ced8db8ad4e2f0216 (patch)
tree2eff3dc46c76b8fbd72c2da5640dcddaaf77a59d /gnu
parent0122f1e294b8411238640922508784c28070fe71 (diff)
gnu: file-roller: Update to 3.42.0.
* gnu/packages/gnome.scm (file-roller): Update to 3.42.0. [arguments]: New field. [native-inputs]: Replace intltool with gettext-minimal. Remove gtk+:bin. [inputs]: Remove gdk-pixbuf. Add libhandy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c32d5ac929..0dfb88570a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7410,7 +7410,7 @@ share them with others via social networking and more.")
(define-public file-roller
(package
(name "file-roller")
- (version "3.40.0")
+ (version "3.42.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/file-roller/"
@@ -7418,22 +7418,27 @@ share them with others via social networking and more.")
"file-roller-" version ".tar.xz"))
(sha256
(base32
- "039w1dcpa5ypmv6sm634alk9vbcdkyvy595vkh5gn032jsiqca2a"))))
+ "1iq24g2z7kf1a6kn9asp96lc59r8pxxjvcmm5r7zy47cadnqwhqw"))))
(build-system meson-build-system)
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'install 'disable-gtk-update-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
(native-inputs
- (list desktop-file-utils ; for update-desktop-database
- intltool
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
itstool
pkg-config
- python
- `(,gtk+ "bin") ; gtk-update-icon-cache
- `(,glib "bin")))
+ python))
;; TODO: Add libnautilus.
(inputs
(list gtk+
- gdk-pixbuf
json-glib
libarchive
+ libhandy
libnotify
nettle
libxml2))