summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 10:51:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:07 +0200
commitfb727d8e3caf4dd1d427a128d2d420fcb043231c (patch)
tree80b00683e869c5af116514beb61d18bda6c0bd27 /gnu
parentcb21c91e4546a89fa0fe01d98d44dacbd5e6c080 (diff)
gnu: Add texlive-ebong.
* gnu/packages/tex.scm (texlive-ebong): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e459415bf9..bc0a64bab0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11104,6 +11104,28 @@ optionally be replaced with graphics paths so that applications that do not
support SVG fonts are enabled to render the graphics properly.")
(license license:gpl3+)))
+(define-public texlive-ebong
+ (package
+ (name "texlive-ebong")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ebong/" "scripts/ebong/")
+ (base32
+ "0ivzr6d83ws7q00k71zdz1v25y88fhja1safc4jfvd45i58fccy7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ebong.py")))
+ (inputs (list python))
+ (home-page "https://ctan.org/pkg/ebong")
+ (synopsis "Utility for writing Bengali in Rapid Roman Format")
+ (description
+ "This package provides a tool (preprocessor) for writing your
+@code{pRaa-ne-r} ka-thaa in the Bengali langauage. It allows one to write the
+text in Rapid Roman Bangla and convert it to the BangTeX format by a Python
+program. All LaTeX markups are preserved in the target file.")
+ (license license:public-domain)))
+
(define-public texlive-eijkhout
(package
(name "texlive-eijkhout")