summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 21:25:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:03 -0400
commitff1b08f7c49ad0d7029093847b7c697fee4a04ce (patch)
tree26fb2b8dbd34d43fb978bcbc04de897489c27539 /gnu
parent04624f006f447b28319901d7f5d5858000ea8bf1 (diff)
gnu: Remove python2-steadymark.
* gnu/packages/python-xyz.scm (python2-steadymark): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 079b943c0e..3e9d53b720 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20579,43 +20579,6 @@ while only declaring the test-specific fields.")
(define-public python2-misaka
(package-with-python2 python-misaka))
-(define-public python2-steadymark
- ;; This is forced into being a python2 only variant
- ;; due to its dependence on couleur that has no support
- ;; for python3
- (package
- (name "python2-steadymark")
- (version "0.7.3")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "steadymark" version))
- (sha256
- (base32
- "1640i9g8dycql3cc8j0bky0jkzj0q39blfbp4lsgpkprkfgcdk8v"))))
- (build-system python-build-system)
- (native-inputs
- (list python2-couleur python2-sure python2-misaka))
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- ;; Update requirements from dependency==version
- ;; to dependency>=version
- (substitute* "setup.py"
- (("==") ">="))
- #t)))))
- (home-page "https://github.com/gabrielfalcao/steadymark")
- (synopsis "Markdown-based test runner for python")
- (description
- "@code{Steadymark} allows documentation to be written in github-flavoured
- markdown. The documentation may contain snippets of code surrounded by python
- code blocks and @code{Steadymark} will find these snippets and run them, making
- sure that there are no old malfunctional examples in the documentation examples.")
- (license license:expat)))
-
(define-public python-jsonpointer
(package
(name "python-jsonpointer")