summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/hurd.scm7
-rw-r--r--gnu/packages/patches/mig-cpu.h-generation.patch16
3 files changed, 3 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0d0f8c1937..b85be30838 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1594,7 +1594,6 @@ dist_patch_DATA = \
%D%/packages/patches/mia-vtk9.patch \
%D%/packages/patches/mia-vtk92.patch \
%D%/packages/patches/mia-vtk-version.patch \
- %D%/packages/patches/mig-cpu.h-generation.patch \
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
%D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
%D%/packages/patches/mingw-w64-reproducible-gendef.patch \
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 3785c47750..b184657fb9 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -91,10 +91,10 @@
(define-public mig
(package
(name "mig")
- (version "1.8+git20220827")
+ (version "1.8+git20230520")
(source (origin
(method url-fetch)
- ;; XXX: Version 2.35 of glibc can only be built with an
+ ;; XXX: Versions 2.35 and 2.37 of glibc can only be built with an
;; unreleased version of MiG:
;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
;; It cannot be fetched from Git though, as the extra dependency
@@ -103,8 +103,7 @@
version ".tar.gz"))
(sha256
(base32
- "163d37s9lscd6zxyfng421m9nl857464mgjj90xsrcl5ykbng5p2"))
- (patches (search-patches "mig-cpu.h-generation.patch"))))
+ "1ap31jd9jkvvz3vb88hg19cyqmqzmra724yl1xhcrv7gcgnan7d9"))))
(build-system gnu-build-system)
;; Flex is needed both at build and run time.
(inputs (list gnumach-headers flex))
diff --git a/gnu/packages/patches/mig-cpu.h-generation.patch b/gnu/packages/patches/mig-cpu.h-generation.patch
deleted file mode 100644
index 3030eaeaa6..0000000000
--- a/gnu/packages/patches/mig-cpu.h-generation.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Backport MiG commit 73fbf2504ae606dda81372701a67dad6fee0865e:
-
- From: Flavio Cruz <flaviocruz@gmail.com>
- Subject: Generate cpu.h with -ffreestanding
-
---- a/Makefile.in 2023-03-26 23:02:51.384318331 +0200
-+++ b/Makefile.in 2023-03-26 23:03:03.300329369 +0200
-@@ -1051,7 +1051,7 @@ uninstall-am: uninstall-binSCRIPTS unins
- .sym.symc:
- $(AWK_V) $(AWK) -f $(srcdir)/gensym.awk $< > $@
- .symc.symo:
-- $(AM_V_CC) $(TARGET_CC) -S $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -x c -o $@ $<
-+ $(AM_V_CC) $(TARGET_CC) -S $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -ffreestanding -x c -o $@ $<
- .symo.h:
- $(AM_V_GEN) sed -e '/^[^*].*$$/d' -e 's/^[*]/#define/' -e 's/mAgIc[^-0-9]*//' \
- $< > $@