summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ea6fc83bbf..fb5d2fd16a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3991,9 +3991,12 @@ services for your Python modules and applications.")
`(#:phases (modify-phases %standard-phases
(add-after
'install 'check-installed
- (lambda _
+ (lambda* (#:key outputs inputs #:allow-other-keys)
(begin
(setenv "HOME" (getcwd))
+ ;; Make installed package available for running the
+ ;; tests
+ (add-installed-pythonpath inputs outputs)
(and (zero? (system* "python" "selftest.py"
"--installed"))
(zero? (system* "python" "test-installed.py"))))))