summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7d3e2dc17e..561f41cccf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23634,6 +23634,7 @@ automatically fetched from well-curated sources, and formatted as BibTeX.")
(build-system emacs-build-system)
(arguments
(list
+ #:emacs emacs-no-x
#:tests? #true
#:test-command #~(list "emacs" "--batch" "-L" "."
"-l" "test/citar-test.el"
@@ -23643,10 +23644,7 @@ automatically fetched from well-curated sources, and formatted as BibTeX.")
#:phases #~(modify-phases %standard-phases
(add-before 'build 'set-home
(lambda _
- (setenv "HOME" "/tmp")))
- ;; XXX: The following phase reports bogus errors. Suppress
- ;; it for now.
- (delete 'validate-compiled-autoloads))))
+ (setenv "HOME" "/tmp"))))))
(propagated-inputs (list emacs-auctex
emacs-citeproc-el
emacs-embark