summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-web.scm22
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 59312f791a..e92e04979e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 Adam Kandur <kefironpremise@gmail.com>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
@@ -358,6 +359,27 @@ decode/encode structures and slices.")
decompose request handling into many smaller layers.")
(license license:expat)))
+(define-public go-github-com-goccy-go-json
+ (package
+ (name "go-github-com-goccy-go-json")
+ (version "0.9.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/goccy/go-json")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bg8p4c6r8r0kixdxv2m8xmdsmb1zl5sd8czswpccldjk3c358wp"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/goccy/go-json"))
+ (home-page "https://github.com/goccy/go-json")
+ (synopsis "JSON encoder/decoder in Go")
+ (description "Fast JSON encoder/decoder compatible with encoding/json for Go.")
+ (license license:expat)))
+
(define-public go-github-com-google-safehtml
(package
(name "go-github-com-google-safehtml")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index beb14e0c3f..f601d315af 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4174,28 +4174,6 @@ loading algorithms.")
is similar to Go's standard library @code{json} and @code{xml} package.")
(license license:expat)))
-(define-public go-github-com-goccy-go-json
- (package
- (name "go-github-com-goccy-go-json")
- (version "0.9.10")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/goccy/go-json")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1bg8p4c6r8r0kixdxv2m8xmdsmb1zl5sd8czswpccldjk3c358wp"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/goccy/go-json"))
- (home-page "https://github.com/goccy/go-json")
- (synopsis "JSON encoder/decoder in Go")
- (description
- "Fast JSON encoder/decoder compatible with encoding/json for Go.")
- (license license:expat)))
-
(define-public go-github-com-getsentry-raven-go
(let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
(revision "0"))