summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9682dbcad8..84c0c577fb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4323,6 +4323,30 @@ Features include:
(propagated-inputs
(list go-gopkg-in-yaml-v3))))
+(define-public go-github-com-technoweenie-multipartstreamer
+ (package
+ (name "go-github-com-technoweenie-multipartstreamer")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/technoweenie/multipartstreamer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "159jhcabdkds8m5777zfs8p5z3snpjhzz7q9aq9wjpcvh6xlljqa"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:tests? #f ; Upstream tests are broken.
+ #:import-path "github.com/technoweenie/multipartstreamer"))
+ (home-page "https://github.com/technoweenie/multipartstreamer")
+ (synopsis "MIME multipart format streamer")
+ (description
+ "This package helps you encode large files in MIME multipart format
+without reading the entire content into memory.")
+ (license license:expat)))
+
(define-public go-github-com-tevino-abool
(let ((commit
"3c25f2fe7cd0ef3eabefce1d90efd69a65d35b12")