summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/fonts.scm2
-rw-r--r--gnu/packages/fontutils.scm25
-rw-r--r--gnu/packages/graphics.scm2
-rw-r--r--gnu/packages/pdf.scm2
-rw-r--r--gnu/packages/python-xyz.scm90
5 files changed, 61 insertions, 60 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 7830c47219..39caa3d0c4 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2469,7 +2469,7 @@ It comes in seven weights and Roman, Italic and Oblique styles.")
`(("fontforge" ,fontforge)
("harfbuzz" ,harfbuzz "bin")
("python" ,python-minimal)
- ("python-fonttools" ,python-fonttools)
+ ("python-fonttools-minimal" ,python-fonttools-minimal)
("python-brotli" ,python-brotli)))
(arguments
`(#:make-flags (list "PY=python3"
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 152da73a7e..b32d76c15a 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -379,7 +379,7 @@ but also provides many useful font conversion and analysis facilities.
(invoke "pytest" "-vv")))))))
(native-inputs (list python-pytest python-setuptools-scm python-wheel))
(inputs (list python-afdko))
- (propagated-inputs (list python-fonttools))
+ (propagated-inputs (list python-fonttools-minimal))
(home-page "https://github.com/adobe-type-tools/cffsubr")
(synopsis "Compact Font Format (CFF) subroutinizer")
(description "This package provides the @command{cffsubr} command, a
@@ -409,7 +409,7 @@ Kit for OpenType (AFDKO) @command{tx} tool.")
((", \"setuptools_git_ls_files\"") "")))))))
(native-inputs (list python-pytest python-pytest-runner
python-setuptools-scm))
- (propagated-inputs (list python-fonttools))
+ (propagated-inputs (list python-fonttools-minimal))
(home-page "https://github.com/googlefonts/compreffor")
(synopsis "Compact Font Format (CFF) subroutinizer for fontTools")
(description "This package provides a Compact Font Format (CFF)
@@ -427,7 +427,7 @@ subroutinizer for fontTools.")
(sha256
(base32 "1x762r7bf39g6aivfvrmq00h6f07abvs9x1xm0fz8l81vq8jz64c"))))
(build-system python-build-system)
- (propagated-inputs (list python-fonttools-full))
+ (propagated-inputs (list python-fonttools))
(native-inputs
(list python-cython
python-defcon
@@ -484,7 +484,7 @@ to generate OpenType font binaries from Unified Font Objects (UFOs).")
(sha256
(base32 "070v1jz5f18g15if459ppwswq4w5hzffwp1gvdc5j47bgz5qflva"))))
(build-system python-build-system)
- (propagated-inputs (list python-fonttools))
+ (propagated-inputs (list python-fonttools-minimal))
(native-inputs
(list python-setuptools-scm
python-pytest
@@ -510,7 +510,7 @@ font, glyph, etc. mathematical operations on font data.")
(base32 "1za15dzsnymq6d9x7xdfqwgw4a3003wj75fn2crhyidkfd2s3nd6"))))
(build-system python-build-system)
(arguments (list #:tests? #f))
- (propagated-inputs (list python-fonttools))
+ (propagated-inputs (list python-fonttools-minimal))
(native-inputs (list unzip))
(home-page "https://github.com/robofab-developers/fontPens")
(synopsis "Python classes implementing the pen protocol")
@@ -561,7 +561,7 @@ implementing the pen protocol for manipulating glyphs.")
(list python-booleanoperations
python-defcon-bootstrap
python-fontmath
- python-fonttools))
+ python-fonttools-minimal))
(native-inputs (list python-setuptools-scm unzip))
(home-page "https://github.com/robotools/fontParts")
(synopsis "Library for interacting with font parts")
@@ -645,7 +645,7 @@ to UFOs and DesignSpace files via @code{defcon} and @code{designspaceLib}.")
(invoke "pytest" "-vv" "tests/testusage.py")))))))
(native-inputs (list python-pytest python-setuptools-scm))
(propagated-inputs
- (list python-defcon python-fonttools python-glyphslib))
+ (list python-defcon python-fonttools-minimal python-glyphslib))
(home-page "https://github.com/googlefonts/glyphsets/")
(synopsis "Evaluate coverage of glyph sets")
(description
@@ -701,7 +701,8 @@ different scripts and languages.")
(sha256
(base32 "0r1qq45np49x14zz1zwkaayqrn7m8dn2jlipjldg2ihnmpzw29w1"))))
(build-system python-build-system)
- (propagated-inputs (list python-defcon python-fontmath python-fonttools))
+ (propagated-inputs (list python-defcon python-fontmath
+ python-fonttools-minimal))
(native-inputs (list unzip))
(home-page "https://github.com/LettError/MutatorMath")
(synopsis "Piecewise linear interpolation Python library")
@@ -869,7 +870,7 @@ paths (intersection, union, difference, xor).")
(list python-defcon
python-fontmath
python-fontparts
- python-fonttools
+ python-fonttools-minimal
python-mutatormath))
(native-inputs (list python-setuptools-scm unzip))
(home-page "https://github.com/LettError/ufoProcessor")
@@ -1331,7 +1332,7 @@ applications should be.")
"01jzhwnj1c3d68dmw15jdxly0hwkmd8ja4kw755rbkykn1ly2qyx"))))
(build-system cmake-build-system)
(native-inputs
- (list python python-fonttools))
+ (list python python-fonttools-minimal))
(inputs
(list freetype))
(synopsis "Reimplementation of the SIL Graphite text processing engine")
@@ -1611,7 +1612,7 @@ with @samp{nameIDs}.")
(build-system pyproject-build-system)
(native-inputs
(list python-pytest python-setuptools-scm))
- (propagated-inputs (list python-attrs python-fonttools-full))
+ (propagated-inputs (list python-attrs python-fonttools))
(home-page "https://github.com/fonttools/ufoLib2")
(synopsis "Unified Font Object (UFO) font processing library")
(description "The ufoLib2 Python library is meant to be a thin
@@ -1635,7 +1636,7 @@ API-compatible with defcon.")
(sha256
(base32 "0i1a306b8c42dpbplwxj6ili2aac5lwq2ir6r1jswicysvk9dqxf"))))
(build-system python-build-system)
- (propagated-inputs (list python-fontpens-bootstrap python-fonttools-full))
+ (propagated-inputs (list python-fontpens-bootstrap python-fonttools))
(native-inputs
(list python-pytest
python-pytest-runner
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index e650ef55ae..e059e1afcf 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -938,7 +938,7 @@ basic geometries.")
(sha256
(base32 "1f41lb19m8azchl1aqz6j5ycbspb8jsf1cnn42hlydxd68f85ylc"))))
(build-system python-build-system)
- (propagated-inputs (list python-fonttools python-pyclipper))
+ (propagated-inputs (list python-fonttools-minimal python-pyclipper))
(native-inputs
(list python-defcon-bootstrap
python-fontpens-bootstrap
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 89eb6f48d0..ff7d895774 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1615,7 +1615,7 @@ manipulating PDF documents from the command line. It supports
python-cairosvg
python-cffi
python-cssselect2
- python-fonttools-full
+ python-fonttools
python-html5lib
python-pillow
python-pydyf
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c48b1fb9bc..87ac190581 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7149,7 +7149,7 @@ tests = True~%" (assoc-ref inputs "tcl") (assoc-ref inputs "tk"))))))
python-certifi
python-cycler
python-dateutil
- python-fonttools
+ python-fonttools-minimal
python-kiwisolver
python-numpy
python-packaging
@@ -12188,10 +12188,10 @@ number of lines in the contained files easily.")
(license license:expat)))
;;; Tests are left out in the main package to avoid cycles.
-(define-public python-fonttools
+(define-public python-fonttools-minimal
(hidden-package
(package
- (name "python-fonttools")
+ (name "python-fonttools-minimal")
(version "4.39.3")
(source (origin
(method url-fetch)
@@ -12213,48 +12213,48 @@ also contains a tool called “TTX” which converts TrueType/OpenType fonts to
from an XML-based format.")
(license license:expat))))
-;;; Rename 'python-fonttools' in next cycle, renaming the current
-;;; 'python-fonttools' to 'python-fonttools-minimal'.
-(define-public python-fonttools-full
- (package/inherit python-fonttools
- (arguments
- (substitute-keyword-arguments (package-arguments python-fonttools)
- ((#:tests? _ #f)
- (not (%current-target-system)))
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- "-k"
- ;; XXX: These tests need .trm files that are
- ;; not shipped with the PyPI release.
- (format #f "not ~a"
- (string-join
- '("test_read_fontdimens_mathsy"
- "test_read_fontdimens_mathex"
- "test_read_fontdimens_vanilla"
- "test_read_boundary_char"
- "fontTools.tfmLib"
- ;; The MtiTest tests fail for unknown
- ;; reasons (see:
- ;; https://github.com/fonttools/
- ;; fonttools/issues/3078)
- "MtiTest")
- " and not "))))))))))
- (native-inputs
- (modify-inputs (package-native-inputs python-fonttools)
- (append python-pytest)))
- (propagated-inputs
- (list python-brotli
- python-fs
- python-lxml
- python-lz4
- python-scipy
- python-unicodedata2
- python-zopfli))
- (properties (alist-delete 'hidden? (package-properties python-fonttools)))))
+(define-public python-fonttools
+ (let ((base python-fonttools-minimal))
+ (package/inherit base
+ (name "python-fonttools")
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:tests? _ #f)
+ (not (%current-target-system)))
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv"
+ "-k"
+ ;; XXX: These tests need .trm files that are
+ ;; not shipped with the PyPI release.
+ (format #f "not ~a"
+ (string-join
+ '("test_read_fontdimens_mathsy"
+ "test_read_fontdimens_mathex"
+ "test_read_fontdimens_vanilla"
+ "test_read_boundary_char"
+ "fontTools.tfmLib"
+ ;; The MtiTest tests fail for unknown
+ ;; reasons (see:
+ ;; https://github.com/fonttools/
+ ;; fonttools/issues/3078)
+ "MtiTest")
+ " and not "))))))))))
+ (native-inputs
+ (modify-inputs (package-native-inputs base)
+ (append python-pytest)))
+ (propagated-inputs
+ (list python-brotli
+ python-fs
+ python-lxml
+ python-lz4
+ python-scipy
+ python-unicodedata2
+ python-zopfli))
+ (properties (alist-delete 'hidden? (package-properties base))))))
(define-public python-ly
(package