summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dbcf018527..f05d6271cc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8010,6 +8010,47 @@ are met.")
(properties '((hidden? . #t)))
(license (list license:expat license:asl2.0))))
+(define-public rust-stdweb-0.4
+ (package
+ (name "rust-stdweb")
+ (version "0.4.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "stdweb" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "094giad1v81rxxs4izf88ijc9c6w3c7cr5a7cwwr86mc22xn4hy3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-discard" ,rust-discard-1.0)
+ ("rust-futures-channel-preview" ,rust-futures-channel-preview-0.3)
+ ("rust-futures-core-preview" ,rust-futures-core-preview-0.3)
+ ("rust-futures-executor-preview" ,rust-futures-executor-preview-0.3)
+ ("rust-futures-util-preview" ,rust-futures-util-preview-0.3)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-json" ,rust-serde-json-1.0)
+ ("rust-stdweb-derive" ,rust-stdweb-derive-0.5)
+ ("rust-stdweb-internal-macros" ,rust-stdweb-internal-macros-0.2)
+ ("rust-stdweb-internal-runtime" ,rust-stdweb-internal-runtime-0.1)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2))
+ #:cargo-development-inputs
+ (("rust-rustc-version" ,rust-rustc-version-0.2)
+ ("rust-serde-derive" ,rust-serde-derive-1.0)
+ ("rust-serde-json" ,rust-serde-json-1.0)
+ ("rust-stdweb-internal-test-macro" ,rust-stdweb-internal-test-macro-0.1)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.2))))
+ (home-page "https://github.com/koute/stdweb")
+ (synopsis "Standard library for the client-side Web")
+ (description
+ "This package provides a standard library for the client-side
+Web.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-stdweb-derive-0.5
(package
(name "rust-stdweb-derive")