summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c79058ab42..b82987e7a2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1824,6 +1824,12 @@ the resulting text.")
(arguments `(#:tests? #f ; Tests require googletest *sources*
#:phases
(modify-phases %standard-phases
+ (add-after 'install 'delete-formulas-log
+ ;; Contains date and timing information which is unreproducible,
+ ;; and should not be needed when using the package
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file (string-append out "/share/doc/itpp/html/_formulas.log")))))
(add-after 'unpack 'set-man-page-date
(lambda _
(substitute* "itpp-config.1.cmake.in"