summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm64
1 files changed, 4 insertions, 60 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 175c5e1b84..c13520e736 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1470,71 +1470,15 @@ Knuth, including the plain format, plain base, and the MF logo fonts.")
"1bzqzzhs15w7dqz90hfjnaffjqh24q14w2h1h8vnxzvrlsyv21vq")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments
- (list
- #:texlive-latex-base #f
- #:modules
- '((guix build texlive-build-system)
- (guix build utils)
- (srfi srfi-1)
- (srfi srfi-26))
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'install 'generate-fonts-metrics
- (lambda _
- (let ((cm #$(this-package-native-input "texlive-cm"))
- (metafont #$(this-package-native-input "texlive-metafont"))
- (fonts-directories
- (delete-duplicates
- (map (lambda (f)
- (string-drop (dirname f) (string-length "./")))
- (find-files "." "[0-9]+\\.mf$"))))
- (root (getcwd)))
- (mkdir-p "build")
- ;; Tell mf where to find mf.base.
- (setenv "MFBASES"
- (string-append metafont "/share/texmf-dist/web2c/"))
- (for-each
- (lambda (directory)
- ;; Tell mf where to look for source files.
- (setenv "MFINPUTS"
- (string-append
- (getcwd) "/" directory ":"
- metafont "/share/texmf-dist/metafont/base/:"
- cm "/share/texmf-dist/fonts/source/public/cm/"))
- ;; Build font metrics (tfm).
- (with-directory-excursion directory
- (for-each (lambda (font)
- (format #t "building font ~a\n" font)
- (invoke "mf" "-progname=mf"
- (string-append "-output-directory="
- root "/build")
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "batchmode; "
- "input "
- (basename font ".mf"))))
- (find-files "." "[0-9]+\\.mf$")))
- ;; Install font metrics at the appropriate location.
- (let ((destination
- ;; fonts/source/xxx/yyy/... -> fonts/tfm/xxx/yyy/...
- (string-append "fonts/tfm"
- (string-drop
- directory
- (string-length "fonts/source")))))
- (format #t "moving font metrics in ~a\n" destination)
- (for-each (cut install-file <> destination)
- (find-files "build/" "\\.tfm$"))))
- fonts-directories)))))))
- (native-inputs
- (list texlive-bin texlive-cm texlive-metafont))
+ (arguments (list #:texlive-latex-base #f))
+ (native-inputs (list texlive-cm texlive-metafont))
(home-page "https://ctan.org/pkg/latex-fonts")
(synopsis "Collection of fonts used in LaTeX distributions")
(description
"This is a collection of fonts for use with standard LaTeX packages and
classes. It includes invisible fonts (for use with the slides class), line and
-circle fonts (for use in the picture environment) and LaTeX symbol fonts.")
+circle fonts (for use in the @code{picture} environment) and LaTeX symbol
+fonts.")
(license license:lppl1.2+)))
(define-deprecated-package texlive-fonts-latex texlive-latex-fonts)