summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad49f6ed25..9248475eb8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11564,6 +11564,13 @@ environment.")
(substitute* "meson/meson-postinstall.sh"
(("gtk-update-icon-cache") (which "true")))
#t))
+ (add-after 'install 'fix-desktop-file
+ ;; Hardcode launcher to be on the safe side
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/share/applications/"
+ "org.gnome.Polari.desktop")
+ (("Exec=.*") "Exec=" out "/bin/polari")))))
(add-after 'glib-or-gtk-wrap 'wrap-typelib
(lambda* (#:key outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")