summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 1 insertions, 33 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d88b98e38e..b777c935b3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1554,39 +1554,7 @@ circle fonts (for use in the picture environment) and LaTeX symbol fonts.")
"1r53qlrcqfwc0dfr7ji1nxnqrj6n0qrlg1rl7fjlw6ap3q9y434k")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'build 'build-font-metrics
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((root (assoc-ref inputs "source"))
- (mf #$(this-package-native-input "texlive-metafont"))
- (kl #$(this-package-native-input "texlive-knuth-lib")))
- ;; Tell mf where to find mf.base.
- (setenv "MFBASES"
- (string-append mf "/share/texmf-dist/web2c"))
- ;; Tell mf where to look for source files.
- (setenv "MFINPUTS"
- (string-append root ":"
- mf "/share/texmf-dist/metafont/base:"
- kl "/share/texmf-dist/fonts/source/public/knuth-lib:"
- root "/fonts/source/public/mflogo/"))
- (for-each (lambda (font)
- (format #t "building font ~a\n" font)
- (invoke "mf" "-progname=mf"
- "-output-directory=build"
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "scrollmode; "
- "input " (basename font))))
- (find-files
- (string-append root
- "/fonts/source/public/mflogo/")
- "\\.mf$"))))))))
- (native-inputs
- (list texlive-bin texlive-knuth-lib texlive-metafont))
+ (native-inputs (list texlive-knuth-lib texlive-metafont))
(home-page "https://ctan.org/pkg/mflogo")
(synopsis "LaTeX support for Metafont logo fonts")
(description