summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e7d9af1b34..541be156ae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11996,32 +11996,28 @@ page (also known as end notes).")
(license license:lppl1.3c+)))
(define-public texlive-titling
- (let ((template (simple-texlive-package
- "texlive-titling"
- (list "/doc/latex/titling/"
- "/source/latex/titling/")
- (base32
- "0pc3806kc9p2dizdghis0p0b00xs0gmlh2nmf94f5wasz5mkw6bk"))))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "latex/titling")
- ((#:build-targets _ '())
- ''("titling.ins"))
- ((#:tex-format _ "latex") "latex")))
- (native-inputs
- (list texlive-cm))
- (home-page "https://www.ctan.org/pkg/titling")
- (synopsis "Control typesetting of the \\maketitle command")
- (description "The @code{titling} package provides control over the
-typesetting of the @code{\\maketitle} command and @code{\\thanks} commands,
-and makes the \title, @code{\\author} and @code{\\date} information
-permanently available. Multiple titles are allowed in a single document. New
-titling elements can be added and a @code{titlepage} title can be centered on
+ (package
+ (name "texlive-titling")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/titling/" "source/latex/titling/"
+ "tex/latex/titling/")
+ (base32
+ "1wp5r6wwrz1nx3wrmc0hxjfapqppcb126l4wmmzh14sfb1py7mz4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (home-page "https://ctan.org/pkg/titling")
+ (synopsis "Control typesetting of the @code{\\maketitle} command")
+ (description
+ "The @code{titling} package provides control over the typesetting of the
+@code{\\maketitle} command and @code{\\thanks} commands, and makes the
+@code{\\title}, @code{\\author} and @code{\\date} information permanently
+available. Multiple titles are allowed in a single document. New titling
+elements can be added and a @code{titlepage} title can be centered on
a physical page.")
- (license license:lppl))))
+ (license license:lppl)))
(define-public texlive-ifoddpage
(package