summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 67176eb5a9..9e8d3fa5f8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1048,6 +1048,11 @@ protocols used in KDE Plasma.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-specific-tests
+ (lambda _
+ ;; PlasmaWindowModelTest::testChangeWindowAfterModelDestroy(icon)
+ (substitute* "autotests/client/test_plasma_window_model.cpp"
+ ((".*changedSpy\\.wait.*") ""))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(setenv "XDG_RUNTIME_DIR" (getcwd))