summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ae5b85d9d0..f42b5064c9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5211,6 +5211,22 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
"tests/libedata-cal/test-cal-cache-utils.c")
(("/bin/rm") (which "rm")))
#t))
+ ;; This phase fixes locale canonicalization when using newer
+ ;; versions of ICU. The bug has been fixed upstream, and
+ ;; should appear starting in version 3.33.5.
+ ;; <https://gitlab.gnome.org/GNOME/evolution-data-server/issues/137>.
+ (add-after 'unpack 'patch-locale-canonicalization
+ (lambda _
+ (substitute* "src/libedataserver/e-collator.c"
+ (("len = uloc_canonicalize \\(posix_locale,.*" x)
+ ((lambda (xs) (string-join xs "\n" 'suffix))
+ (list
+ "if (posix_locale && ("
+ " g_ascii_strcasecmp(posix_locale, \"C\") == 0 ||"
+ " g_ascii_strcasecmp(posix_locale, \"POSIX\") == 0))"
+ " posix_locale = \"en_US_POSIX\";"
+ x))))
+ #t))
(add-before 'configure 'dont-override-rpath
(lambda _
(substitute* "CMakeLists.txt"