summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c5ec7bcdc2..5b88a9d31e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -276,11 +276,13 @@ output. Experimental backends include OpenGL, BeOS, OS/2, and DirectFB.")
;; There are all in the Requires or Requires.private field of '.pc'.
(list glib graphite2 icu4c))
(native-inputs
- (list `(,glib "bin") ;for glib-mkenums
- gobject-introspection
- pkg-config
- python-wrapper
- which))
+ (append (list `(,glib "bin")) ;for glib-mkenums
+ (if (target-hurd?)
+ '()
+ (list gobject-introspection))
+ (list pkg-config
+ python-wrapper
+ which)))
(arguments
(list #:configure-flags
#~(list "--with-graphite2"