summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 811e293c1d..4462805ddd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14962,6 +14962,31 @@ letter of Pinyin to Simplified/Traditional Chinese characters.")
methods from a given list.")
(license license:gpl3+)))
+(define-public emacs-mini-frame
+ (let ((commit "60838f3cab438dcbda8eaa15ab3e5d1af88910e9")
+ (revision "0"))
+ (package
+ (name "emacs-mini-frame")
+ (version (git-version "1.19" revision commit))
+ (source
+ (origin
+ (uri (git-reference
+ (url "https://github.com/muffinmad/emacs-mini-frame.git")
+ (commit commit)))
+ (method git-fetch)
+ (sha256
+ (base32 "0q01iymz657bg3mcmq7vcl8r0ypsa1pqj1p6gxs7ywx1d33lan4d"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/muffinmad/emacs-mini-frame")
+ (synopsis "Show minibuffer in child frame")
+ (description
+ "@dfn{mini-frame-mode} adds an advice around @code{read-from-minibuffer}
+to show the minibuffer as a child frame on top of the current frame.
+@code{find-file} and similar functions associated mini-buffers may appear at
+the center of the screen and not at the bottom.")
+ (license license:gpl3+))))
+
(define-public emacs-posframe
(package
(name "emacs-posframe")