summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 8afb2c3293..30ef673f7d 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -876,10 +876,13 @@ commands part of the U-Boot project, such as Patman.")))
#:tests? #f
#:phases
#~(modify-phases %standard-phases
+ ;; Patman fails to run during 'sanity-check phase, as it needs to be
+ ;; run within a git directory.
+ (delete 'sanity-check)
(add-after 'unpack 'chdir
(lambda _
(chdir "tools/patman"))))))
- (inputs (list python-pygit2 python-requests))
+ (inputs (list python-pygit2 python-requests python-u-boot-pylib))
(synopsis "Patch automation tool")
(description "Patman is a patch automation script which:
@itemize