summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 9064ca3822..bc14286070 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -324,7 +324,10 @@ and workspaces that can be used in the compiler environment of your choice.")
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(let ((skipped-tests (list #$@%common-disabled-tests
;; This test requires the bundled libuv.
- "BootstrapTest")))
+ "BootstrapTest"
+ #$@(if (system-hurd?)
+ %common-disabled-tests/hurd
+ #~()))))
(if tests?
(begin
(invoke "ctest" "-j" (if parallel-tests?