summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 67de332f12..3b6c5be991 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -144,3 +145,32 @@
(modules '((guix build utils)))
(snippet
'(begin (delete-file-recursively "botan")))))))
+
+(define-public rust-c2-chacha-0.2
+ (package
+ (name "rust-c2-chacha")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "c2-chacha" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00a11qdc8mg3z0k613rhprkc9p6xz0y7b1681x32ixg0hr3x0r3x"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-ppv-lite86" ,rust-ppv-lite86-0.2)
+ ("rust-stream-cipher" ,rust-stream-cipher-0.3))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.2))))
+ (home-page "https://github.com/cryptocorrosion/cryptocorrosion")
+ (synopsis "The ChaCha family of stream ciphers")
+ (description
+ "The ChaCha family of stream ciphers.")
+ (license (list license:asl2.0 license:expat))))