summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index caf514068e..0dfe93f8f4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7394,6 +7394,27 @@ with the Unicode character database.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-unchecked-index-0.2
+ (package
+ (name "rust-unchecked-index")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "unchecked-index" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0p6qcai1mjayx59cpgk27d0zgw9hz9r1ira5jiqil66f4ba8dfpf"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/bluss/unchecked-index")
+ (synopsis "Unchecked indexing wrapper using regular index syntax")
+ (description
+ "Unchecked indexing wrapper using regular index syntax.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-unicase-2.4
(package
(name "rust-unicase")