summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 26 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a363fe5349..ae0be74b01 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -60572,8 +60572,33 @@ deeply recursive algorithms that may accidentally blow the stack.")
(description "New standard library, old compiler.")
(license (list license:expat license:asl2.0))))
+(define-public rust-state-0.5
+ (package
+ (name "rust-state")
+ (version "0.5.3")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "state" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fzji31ijbkimbzdy4dln9mp5xp7lm1a0dnqxv4n10hywphnds6v"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-loom" ,rust-loom-0.5))
+ #:cargo-development-inputs
+ (("rust-static-assertions" ,rust-static-assertions-1))))
+ (home-page "https://github.com/SergioBenitez/state")
+ (synopsis "Library for safe global and thread-local state management")
+ (description
+ "This package provides a library for safe global and thread-local state
+management.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-state-0.4
(package
+ (inherit rust-state-0.5)
(name "rust-state")
(version "0.4.2")
(source
@@ -60583,17 +60608,10 @@ deeply recursive algorithms that may accidentally blow the stack.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "10v4k9bgjryc9m40c8nnhyrby2ngkhpx841p3k4halgxlp8af59h"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-lazy-static" ,rust-lazy-static-1))))
- (home-page "https://github.com/SergioBenitez/state")
- (synopsis "Library for safe global and thread-local state management")
- (description
- "This package provides a library for safe global and thread-local state
-management.")
- (license (list license:expat license:asl2.0))))
+ (("rust-lazy-static" ,rust-lazy-static-1))))))
(define-public rust-static-assertions-1
(package