summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad3603b205..4b2fc8f0dc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3024,6 +3024,28 @@ an interactive shell, and look up definitions and documentation as well as
code completion and project management support.")
(license license:gpl3+)))
+(define-public emacs-auto-compile
+ (package
+ (name "emacs-auto-compile")
+ (version "1.7.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacscollective/auto-compile.git")
+ (commit version)))
+ (sha256
+ (base32
+ "1njnyilv6lxnbvi6yrgzg6qjhf6vgh4fpag4hav1j45718y6kd31"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat emacs-packed))
+ (home-page "https://github.com/emacscollective/auto-compile")
+ (synopsis "Automatically compile Emacs Lisp libraries")
+ (description
+ "This package provides two minor modes which automatically recompile
+Emacs Lisp source files. Together, these modes guarantee that Emacs never
+loads outdated byte code files.")
+ (license license:gpl3+)))
+
(define-public emacs-auto-sudoedit
(package
(name "emacs-auto-sudoedit")