summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f1fbd7d9ee..cb8495f8e8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -126,6 +126,7 @@
;;; Copyright © 2020, 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1768,7 +1769,7 @@ Apprentice and Sourcerer.")
(define-public emacs-suneater-theme
(package
(name "emacs-suneater-theme")
- (version "2.2.1")
+ (version "2.3.0")
(source
(origin
(method git-fetch)
@@ -1777,7 +1778,7 @@ Apprentice and Sourcerer.")
(commit version)))
(sha256
(base32
- "1pnfiwnh2hr2hp4rxivx61j3hrmvwingjpfslnn535a3z9md0c4f"))
+ "19432hb4lkfvip72wrc9nqq5bc10nv0g4547x2sif5iqak43dw72"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(home-page "https://git.sr.ht/~plattfot/suneater-theme")
@@ -31372,6 +31373,28 @@ name (with autocompletion), a simple bookmark management system and
connections using TLS encryption.")
(license license:gpl3+)))
+(define-public emacs-gemini
+ (package
+ (name "emacs-gemini")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.carcosa.net/jmcbray/gemini.el")
+ (commit "a7dd7c6ea4e036d0d5ecc4a5d284874c400f10ba")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pvlk56mhh4xh4gwzqldfk79jsjbcpivv5scd9811pv3afc30gsx"))))
+ (build-system emacs-build-system)
+ (home-page "https://git.carcosa.net/jmcbray/gemini.el")
+ (synopsis "Syntax highlighting for text/gemini")
+ (description
+ "This is a very simple syntax-highlighting mode for text/gemini documents.
+Currently, support is not complete, but it should be enough to help with basic
+documents.")
+ (license license:agpl3+)))
+
(define-public emacs-zerodark-theme
(package
(name "emacs-zerodark-theme")