summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm111
1 files changed, 107 insertions, 4 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 2452a1c810..03a1f6f796 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -17,6 +17,8 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -239,8 +241,11 @@ provide serif, sans and monospaced variants.")
(description "Vera is a sans-serif typeface from Bitstream, Inc. This
package provides the TrueType (TTF) files.")
(license
- (license:x11-style
- "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
+ (license:fsdg-compatible
+ "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
+ "The Font Software may be sold as part of a larger software package but
+no copy of one or more of the Font Software typefaces may be sold by
+itself."))))
(define-public font-cantarell
(package
@@ -316,7 +321,7 @@ sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
(version "2.00.1")
(source (origin
(method url-fetch)
- (uri (string-append "https://fedorahosted.org/releases/l/i/"
+ (uri (string-append "https://releases.pagure.org/"
"liberation-fonts/liberation-fonts-ttf-"
version ".tar.gz"))
(sha256
@@ -350,7 +355,7 @@ sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
`(("source" ,source)
("tar" ,tar)
("gzip" ,gzip)))
- (home-page "https://fedorahosted.org/liberation-fonts/")
+ (home-page "https://pagure.io/liberation-fonts/")
(synopsis
"Fonts compatible with Arial, Times New Roman, and Courier New")
(description
@@ -518,6 +523,104 @@ fonts are intended to support the characters necessary to render or display
text in Simplified Chinese, Traditional Chinese, Japanese, and Korean.")
(license license:silofl1.1)))
+(define-public font-cns11643
+ (package
+ (name "font-cns11643")
+ (version "98.1.20170405")
+ (source (origin
+ (method url-fetch)
+ (uri "http://www.cns11643.gov.tw/AIDB/Open_Data.zip")
+ (sha256
+ (base32
+ "02kb3bwjrra0k2hlr2p8xswd2y0xs6j8d9vm6yrby734h02a40qf"))))
+ (outputs '("out" "tw-kai" "tw-sung"))
+ (build-system trivial-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((font-dir "/share/fonts/truetype/cns11643")
+ (out (string-append
+ (assoc-ref %outputs "out") font-dir))
+ (tw-kai (string-append
+ (assoc-ref %outputs "tw-kai") font-dir))
+ (tw-sung (string-append
+ (assoc-ref %outputs "tw-sung") font-dir))
+ (unzip (string-append
+ (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (system* unzip (assoc-ref %build-inputs "source"))
+ (chdir "Open_Data/Fonts/")
+ (install-file "TW-Kai-98_1.ttf" tw-kai)
+ (install-file "TW-Sung-98_1.ttf" tw-sung)
+ (install-file "TW-Kai-98_1.ttf" out)
+ (install-file "TW-Kai-Ext-B-98_1.ttf" out)
+ (install-file "TW-Kai-Plus-98_1.ttf" out)
+ (install-file "TW-Sung-98_1.ttf" out)
+ (install-file "TW-Sung-Ext-B-98_1.ttf" out)
+ (install-file "TW-Sung-Plus-98_1.ttf" out)
+ #t))))
+ (home-page "http://www.cns11643.gov.tw/AIDB/welcome.do")
+ (synopsis "CJK TrueType fonts, TW-Kai and TW-Sung")
+ (description
+ "@code{CNS 11643} character set (Chinese National Standard, or Chinese
+Standard Interchange Code) is the standard character set of the Republic of
+China (Taiwan) for Chinese Characters and other Unicode symbols. Contained
+are six TrueType fonts based on two script styles, Regular script (Kai), and
+Sung/Ming script, each with three variants:
+
+@itemize
+@item @code{CNS 11643} (@code{TW-Kai} and @code{TW-Sung}): Tens of thousands
+of CJK characters from frequency tables published by the Taiwanese
+Ministry of Education. ISO 10646 and Unicode compatible encoding.
+@item @code{Big-5 Plus}: Several thousand frequently used CJK characters
+encoded in the user defined area of the Big-5 code.
+@item @code{Big-5 Extended}: A Big-5 character set based on the
+@code{Big-5 Plus} and @code{CNS 11643} character sets.
+@end itemize\n")
+ (license (license:non-copyleft
+ "http://data.gov.tw/license")))) ; CC-BY 4.0 compatible
+
+(define-public font-cns11643-swjz
+ (package
+ (name "font-cns11643-swjz")
+ (version "1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.moedict.tw/fonts/truetype/cns11643/ebas927.ttf")
+ (sha256
+ (base32
+ "1qkljldbmb53zp1rcmpsb8rzy67rnsqcjxi549m9743ifk4isl78"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((font-dir (string-append %output
+ "/share/fonts/truetype/cns11643"))
+ (source (assoc-ref %build-inputs "source")))
+ (mkdir-p font-dir)
+ (copy-file source
+ (string-append font-dir "/" "ebas927.ttf"))
+ #t))))
+ (home-page
+ (string-append "http://www.cns11643.gov.tw/AIDB/download.do"
+ "?name=%E5%AD%97%E5%9E%8B%E4%B8%8B%E8%BC%89"))
+ (synopsis "TrueType seal script font")
+ (description
+ "@code{Shuowen Jiezi} is a TrueType seal script font based on the ancient
+text of the same name published by the Executive Yuan of Taiwan. 6721 glyphs
+are included, at Unicode compatible code points corresponding to their modern
+variants.")
+ ;; Original text only available in Chinese. More info at
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26703#11
+ (license (license:non-copyleft
+ "http://www.cns11643.gov.tw/AIDB/copyright.do"))))
+
(define-public font-wqy-zenhei
(package
(name "font-wqy-zenhei")