summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index fe2174b106..4dad2418ad 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
+;;; Copyright © 2021, 2022 Nikolay Korotkiy <sikmir@disroot.org>
;;; Copyright © 2022 Roman Scherer <roman.scherer@burningswell.com>
;;;
;;; This file is part of GNU Guix.
@@ -100,6 +100,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
@@ -1322,7 +1323,7 @@ based on the Osmium library.")
(define-public osm2pgsql
(package
(name "osm2pgsql")
- (version "1.5.1")
+ (version "1.7.0")
(source
(origin
(method git-fetch)
@@ -1331,32 +1332,30 @@ based on the Osmium library.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0i18mskcs087dn3f3h9n7j0wafn8502m0h13mrjwin38xsz0crfj"))
+ (base32 "15fxr4xq7siy237763l7nswx7v0swr3qzs2h3zkjzgvajw4p6qii"))
(modules '((guix build utils)))
(snippet
- '(begin
- (delete-file-recursively "contrib/protozero")
- (delete-file-recursively "contrib/libosmium")
- #t))))
+ ;; Remove bundled libraries.
+ '(delete-file-recursively "contrib"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f; tests fail because we need to setup a database
#:configure-flags
- (list (string-append "-DOSMIUM_INCLUDE_DIR="
- (assoc-ref %build-inputs "libosmium")
- "/include")
- (string-append "-DPROTOZERO_INCLUDE_DIR="
- (assoc-ref %build-inputs "protozero")
- "/include"))))
+ (list "-DEXTERNAL_LIBOSMIUM=ON"
+ "-DEXTERNAL_PROTOZERO=ON"
+ "-DEXTERNAL_FMT=ON"
+ "-DEXTERNAL_RAPIDJSON=ON")))
(inputs
(list boost
bzip2
expat
+ fmt
libosmium
lua
postgresql
proj
protozero
+ rapidjson
zlib))
(native-inputs
(list python python-psycopg2))