summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0368ccc223..8be9c55000 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -873,7 +873,7 @@ notebooks and tiling window managers.")
(define-public gpaste
(package
(name "gpaste")
- (version "42.1")
+ (version "42.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -882,12 +882,13 @@ notebooks and tiling window managers.")
(file-name (git-file-name name version))
(sha256
(base32
- "1dlqa69zvzzdxyh21qfrx2nhpfy0fbihxpgkxqmramcgv3h5k4q3"))
+ "0qq2p19p3r3lz8yfynpnf36cipv54bzdbmq1x5zgwhyl4yl41g28"))
(patches
(search-patches "gpaste-fix-paths.patch"))))
(build-system meson-build-system)
(native-inputs
- (list gettext-minimal
+ (list gcr
+ gettext-minimal
gobject-introspection
(list glib "bin") ; for glib-compile-resources
pkg-config
@@ -913,6 +914,9 @@ notebooks and tiling window managers.")
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-introspection-install-dir
(lambda _
+ (substitute* "src/libgpaste/gpaste/gpaste-settings.c"
+ (("@gschemasCompiled@")
+ (string-append #$output "/share/glib-2.0/schemas/")))
(substitute* '("src/gnome-shell/extension.js"
"src/gnome-shell/prefs.js")
(("@typelibPath@")