summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 190cc42950..5a2bbe618a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2293,6 +2293,7 @@ The gnome-about program helps find which version of GNOME is installed.")
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind=libelogind")
+ #:meson ,meson-0.60
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -5815,7 +5816,10 @@ services for numerous locations.")
"-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.
(string-append "-Dc_link_args=-Wl,-rpath=" #$output
- "/lib/gnome-settings-daemon-3.0"))
+ "/lib/gnome-settings-daemon-3.0:"
+ ;; Also add NSS because for some reason Meson
+ ;; > 0.60 does not add it automatically (XXX).
+ (search-input-directory %build-inputs "lib/nss")))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'set-baobab-file-name
@@ -9613,7 +9617,8 @@ can add your own files to the collection.")
"15wmikwk62cdi93gas77nqh4fbhlrxrncyfmcd1gfa34jbn7vnsa"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t
+ `(#:meson ,meson-0.60
+ #:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -9655,6 +9660,8 @@ beautifying border effects.")
(base32
"1qvrxrk1h8bd75xwasxbvlkqrw6xkavjimvc7sslkw6lvb3z86jp"))))
(build-system meson-build-system)
+ (arguments
+ (list #:meson meson-0.60))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
@@ -12022,6 +12029,7 @@ desktop environment.")
gspell
gtk
gjs
+ libadwaita
libsecret
libsoup
telepathy-glib