summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 584e3cf35e..fdf2e9a815 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2451,7 +2451,6 @@ immutability.")
ocaml-stdlib-shims
ocaml-uuidm
ocaml-uutf))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-alcotest))))
(home-page "https://github.com/mirage/alcotest")
(synopsis "Lightweight OCaml test framework")
(description "Alcotest exposes simple interface to perform unit tests. It
@@ -2462,24 +2461,6 @@ displayed at the end of the run (with the full logs ready to inspect), with a
simple (yet expressive) query language to select the tests to run.")
(license license:isc)))
-(define-public ocaml4.07-alcotest
- (package-with-ocaml4.07
- (package
- (inherit ocaml-alcotest)
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mirage/alcotest")
- (commit version)))
- (file-name (git-file-name "ocaml-alcotest" version))
- (sha256
- (base32
- "1frwi185z4aadmaf0vp8xk5227nyg7nmh28ijj5l7ncjr5slvhz8"))))
- (arguments
- `(#:package "alcotest"))
- (properties '()))))
-
(define-public ocaml-expect-test-helpers-core
(package
(name "ocaml-expect-test-helpers-core")