summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fasthenry-spAllocate.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/fasthenry-spAllocate.patch')
-rw-r--r--gnu/packages/patches/fasthenry-spAllocate.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/fasthenry-spAllocate.patch b/gnu/packages/patches/fasthenry-spAllocate.patch
new file mode 100644
index 0000000000..cefd95f539
--- /dev/null
+++ b/gnu/packages/patches/fasthenry-spAllocate.patch
@@ -0,0 +1,15 @@
+Add forward declarations.
+
+--- fasthenry-3.0/src/fasthenry/sparse/spAllocate.c.orig 2015-07-22 09:45:28.864758891 +0200
++++ fasthenry-3.0/src/fasthenry/sparse/spAllocate.c 2015-07-22 13:04:17.579742206 +0200
+@@ -107,7 +107,9 @@
+ #include "spDefs.h"
+
+
+-
++static InitializeElementBlocks( MatrixPtr, int, int );
++static RecordAllocation( MatrixPtr, char* );
++static AllocateBlockOfAllocationList( MatrixPtr );
+
+
+