summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cppcheck-disable-char-signedness-test.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/cppcheck-disable-char-signedness-test.patch b/gnu/packages/patches/cppcheck-disable-char-signedness-test.patch
new file mode 100644
index 0000000000..d39d300f84
--- /dev/null
+++ b/gnu/packages/patches/cppcheck-disable-char-signedness-test.patch
@@ -0,0 +1,27 @@
+https://sources.debian.org/data/main/c/cppcheck/2.10-2/debian/patches/disable-some-tests-about-char-signedness
+https://trac.cppcheck.net/ticket/11537
+
+Description: Disable some tests affected by char signedness.
+Author: Joachim Reichel <reichel@debian.org>
+Bug: https://trac.cppcheck.net/ticket/11537
+
+Index: cppcheck/test/testcondition.cpp
+===================================================================
+--- cppcheck.orig/test/testcondition.cpp
++++ cppcheck/test/testcondition.cpp
+@@ -4939,6 +4939,7 @@ private:
+ "}\n");
+ ASSERT_EQUALS("[test.cpp:4]: (style) Condition 'it!=vector.end()' is always true\n", errout.str());
+
++#if 0
+ // #11303
+ check("void f(int n) {\n"
+ " std::vector<char> buffer(n);\n"
+@@ -4947,6 +4948,7 @@ private:
+ " buffer.back() == '\\0') {}\n"
+ "}\n");
+ ASSERT_EQUALS("[test.cpp:5]: (style) Condition 'buffer.back()=='\\0'' is always false\n", errout.str());
++#endif
+
+ // #9353
+ check("typedef struct { std::string s; } X;\n"