summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-memcached-syntax-warnings.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-memcached-syntax-warnings.patch b/gnu/packages/patches/python-memcached-syntax-warnings.patch
new file mode 100644
index 0000000000..f8690677c0
--- /dev/null
+++ b/gnu/packages/patches/python-memcached-syntax-warnings.patch
@@ -0,0 +1,24 @@
+Problem reported upstream:
+https://github.com/linsomniac/python-memcached/issues/176
+
+---
+ memcache.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/memcache.py b/memcache.py
+index 05b6657..b935681 100644
+--- a/memcache.py
++++ b/memcache.py
+@@ -1300,8 +1300,8 @@ class Client(threading.local):
+ key = key[1]
+ if key is None:
+ raise Client.MemcachedKeyNoneError("Key is None")
+- if key is '':
+- if key_extra_len is 0:
++ if key == '':
++ if key_extra_len == 0:
+ raise Client.MemcachedKeyNoneError("Key is empty")
+
+ # key is empty but there is some other component to key
+--
+2.26.2