summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/kodi-increase-test-timeout.patch18
-rw-r--r--gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch13
-rw-r--r--gnu/packages/patches/kodi-skip-test-449.patch53
-rw-r--r--gnu/packages/patches/u-boot-infodocs-target.patch84
-rw-r--r--gnu/packages/patches/u-boot-patman-fix-help.patch40
-rw-r--r--gnu/packages/patches/u-boot-patman-get-maintainer.patch104
-rw-r--r--gnu/packages/patches/u-boot-patman-local-conf.patch176
7 files changed, 411 insertions, 77 deletions
diff --git a/gnu/packages/patches/kodi-increase-test-timeout.patch b/gnu/packages/patches/kodi-increase-test-timeout.patch
deleted file mode 100644
index 8fb149ff9d..0000000000
--- a/gnu/packages/patches/kodi-increase-test-timeout.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Increase thread timeout to reduce flakiness.
-
-Taken from upstream:
-https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
-
-diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
-index 42fb8c2fc609..40e644c0ed3c 100644
---- a/xbmc/threads/test/TestEvent.cpp
-+++ b/xbmc/threads/test/TestEvent.cpp
-@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
- EXPECT_TRUE(w3.result == NULL);
-
- // this should end given the wait is for only 50 millis
-- EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
-+ EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
-
- EXPECT_TRUE(!w3.waiting);
- EXPECT_TRUE(w3.result == NULL);
diff --git a/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch b/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
index 2f60737e30..99d8a45de6 100644
--- a/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
+++ b/gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch
@@ -3,15 +3,16 @@ connections work we can set them based on SSL_CERT_DIR and SSL_CERT_FILE.
--- a/xbmc/filesystem/CurlFile.cpp
+++ b/xbmc/filesystem/CurlFile.cpp
-@@ -626,5 +626,9 @@
+@@ -626,8 +626,12 @@
if (!m_cipherlist.empty())
g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
-
+
+ // Load certificate data from environment paths
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR"));
+ g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE"));
+
- // enable HTTP2 support. default: CURL_HTTP_VERSION_1_1. Curl >= 7.62.0 defaults to CURL_HTTP_VERSION_2TLS
- g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2_0);
--
- }
+ if (CServiceBroker::GetSettingsComponent()->GetAdvancedSettings()->m_curlDisableHTTP2)
+ g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
+ else
+ // enable HTTP2 support. default: CURL_HTTP_VERSION_1_1. Curl >= 7.62.0 defaults to CURL_HTTP_VERSION_2TLS
+ g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2TLS);
diff --git a/gnu/packages/patches/kodi-skip-test-449.patch b/gnu/packages/patches/kodi-skip-test-449.patch
deleted file mode 100644
index a418239a7c..0000000000
--- a/gnu/packages/patches/kodi-skip-test-449.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-This test fails regularly between 18.0rc3 and 18.0rc5.2
-
-449/520 Test #449: TestWebServer.CanHeadFile................................................***Failed 0.90 sec
-Note: Google Test filter = TestWebServer.CanHeadFile
-[==========] Running 1 test from 1 test case.
-[----------] Global test environment set-up.
-[----------] 1 test from TestWebServer
-[ RUN ] TestWebServer.CanHeadFile
-/tmp/guix-build-kodi-18.0rc5.2.drv-0/kodi-18.0rc5.2-checkout/xbmc/network/test/TestWebServer.cpp:156: Failure
- Expected: "4"
-To be equal to: httpHeader.GetValue("Content-Length").c_str()
- Which is: "0"
-[ FAILED ] TestWebServer.CanHeadFile (6 ms)
-[----------] 1 test from TestWebServer (6 ms total)
-
-[----------] Global test environment tear-down
-[==========] 1 test from 1 test case ran. (635 ms total)
-[ PASSED ] 0 tests.
-[ FAILED ] 1 test, listed below:
-[ FAILED ] TestWebServer.CanHeadFile
-
----
- xbmc/network/test/TestWebServer.cpp | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/xbmc/network/test/TestWebServer.cpp b/xbmc/network/test/TestWebServer.cpp
-index a87d9f4..b2240f4 100644
---- a/xbmc/network/test/TestWebServer.cpp
-+++ b/xbmc/network/test/TestWebServer.cpp
-@@ -520,13 +520,13 @@ TEST_F(TestWebServer, CanNotHeadNonExistingFile)
- ASSERT_FALSE(curl.Exists(CURL(GetUrlOfTestFile("file_does_not_exist"))));
- }
-
--TEST_F(TestWebServer, CanHeadFile)
--{
-- CCurlFile curl;
-- ASSERT_TRUE(curl.Exists(CURL(GetUrlOfTestFile(TEST_FILES_HTML))));
--
-- CheckHtmlTestFileResponse(curl);
--}
-+//TEST_F(TestWebServer, CanHeadFile)
-+//{
-+// CCurlFile curl;
-+// ASSERT_TRUE(curl.Exists(CURL(GetUrlOfTestFile(TEST_FILES_HTML))));
-+//
-+// CheckHtmlTestFileResponse(curl);
-+//}
-
- TEST_F(TestWebServer, CanNotGetNonExistingFile)
- {
---
-2.20.1
-
diff --git a/gnu/packages/patches/u-boot-infodocs-target.patch b/gnu/packages/patches/u-boot-infodocs-target.patch
new file mode 100644
index 0000000000..5b21a99de3
--- /dev/null
+++ b/gnu/packages/patches/u-boot-infodocs-target.patch
@@ -0,0 +1,84 @@
+Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333259
+
+diff --git a/Makefile b/Makefile
+index de5746399a..597a8886c3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2372,7 +2372,7 @@ tcheck:
+ # Documentation targets
+ # ---------------------------------------------------------------------------
+ DOC_TARGETS := xmldocs latexdocs pdfdocs htmldocs epubdocs cleandocs \
+- linkcheckdocs dochelp refcheckdocs
++ linkcheckdocs dochelp refcheckdocs texinfodocs infodocs
+ PHONY += $(DOC_TARGETS)
+ $(DOC_TARGETS): scripts_basic FORCE
+ $(Q)$(MAKE) $(build)=doc $@
+diff --git a/doc/Makefile b/doc/Makefile
+index f5de65e927..d0904a9f99 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -69,6 +69,14 @@ quiet_cmd_sphinx = SPHINX $@ --> file://$(abspath $(BUILDDIR)/$3/$4)
+ htmldocs:
+ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),,$(var)))
+
++texinfodocs:
++ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,texinfo,$(var),texinfo,$(var)))
++
++# Note: the 'info' Make target is generated by sphinx itself when
++# running the texinfodocs target defined above.
++infodocs: texinfodocs
++ $(MAKE) -C $(BUILDDIR)/texinfo info
++
+ linkcheckdocs:
+ @$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,linkcheck,$(var),,$(var)))
+
+@@ -109,6 +117,8 @@ cleandocs:
+ dochelp:
+ @echo ' U-Boot documentation in different formats from ReST:'
+ @echo ' htmldocs - HTML'
++ @echo ' texinfodocs - Texinfo'
++ @echo ' infodocs - Info'
+ @echo ' latexdocs - LaTeX'
+ @echo ' pdfdocs - PDF'
+ @echo ' epubdocs - EPUB'
+diff --git a/doc/conf.py b/doc/conf.py
+index 62c8d31270..3db70f80c1 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -449,7 +449,7 @@ for fn in os.listdir('.'):
+ # One entry per manual page. List of tuples
+ # (source start file, name, description, authors, manual section).
+ man_pages = [
+- (master_doc, 'dasuboot', 'The U-Boot Documentation',
++ (master_doc, 'u-boot', 'The U-Boot Documentation',
+ [author], 1)
+ ]
+
+@@ -463,8 +463,8 @@ man_pages = [
+ # (source start file, target name, title, author,
+ # dir menu entry, description, category)
+ texinfo_documents = [
+- (master_doc, 'DasUBoot', 'The U-Boot Documentation',
+- author, 'DasUBoot', 'One line description of project.',
++ (master_doc, 'u-boot', 'The U-Boot Documentation',
++ author, 'U-Boot', 'Boot loader for embedded systems',
+ 'Miscellaneous'),
+ ]
+
+diff --git a/doc/media/Makefile b/doc/media/Makefile
+index b9b43a34c3..9b32258696 100644
+--- a/doc/media/Makefile
++++ b/doc/media/Makefile
+@@ -22,10 +22,11 @@ $(BUILDDIR)/linker_lists.h.rst: ${API}/linker_lists.h ${PARSER} $(SRC_DIR)/linke
+
+ # Media build rules
+
+-.PHONY: all html epub xml latex
++.PHONY: all html texinfo epub xml latex
+
+ all: $(IMGDOT) $(BUILDDIR) ${TARGETS}
+ html: all
++texinfo: all
+ epub: all
+ xml: all
+ latex: $(IMGPDF) all
diff --git a/gnu/packages/patches/u-boot-patman-fix-help.patch b/gnu/packages/patches/u-boot-patman-fix-help.patch
new file mode 100644
index 0000000000..89bac06c2f
--- /dev/null
+++ b/gnu/packages/patches/u-boot-patman-fix-help.patch
@@ -0,0 +1,40 @@
+Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333156
+
+diff --git a/tools/patman/main.py b/tools/patman/main.py
+index 5a7756a221..bf300c6e64 100755
+--- a/tools/patman/main.py
++++ b/tools/patman/main.py
+@@ -7,6 +7,7 @@
+ """See README for more information"""
+
+ from argparse import ArgumentParser
++import importlib.resources
+ import os
+ import re
+ import shutil
+@@ -163,11 +164,8 @@ elif args.cmd == 'send':
+ fd.close()
+
+ elif args.full_help:
+- tools.print_full_help(
+- os.path.join(os.path.dirname(os.path.realpath(sys.argv[0])),
+- 'README.rst')
+- )
+-
++ with importlib.resources.path('patman', 'README.rst') as readme:
++ tools.print_full_help(str(readme))
+ else:
+ # If we are not processing tags, no need to warning about bad ones
+ if not args.process_tags:
+diff --git a/tools/patman/setup.py b/tools/patman/setup.py
+index 43fdc00ce6..ce9bb4aa63 100644
+--- a/tools/patman/setup.py
++++ b/tools/patman/setup.py
+@@ -7,6 +7,6 @@ setup(name='patman',
+ scripts=['patman'],
+ packages=['patman'],
+ package_dir={'patman': ''},
+- package_data={'patman': ['README']},
++ package_data={'patman': ['README.rst']},
+ classifiers=['Environment :: Console',
+ 'Topic :: Software Development'])
diff --git a/gnu/packages/patches/u-boot-patman-get-maintainer.patch b/gnu/packages/patches/u-boot-patman-get-maintainer.patch
new file mode 100644
index 0000000000..4377f8394e
--- /dev/null
+++ b/gnu/packages/patches/u-boot-patman-get-maintainer.patch
@@ -0,0 +1,104 @@
+Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333427
+
+diff --git a/tools/patman/patman.rst b/tools/patman/patman.rst
+index 7828899879..95b6c9c3f0 100644
+--- a/tools/patman/patman.rst
++++ b/tools/patman/patman.rst
+@@ -88,7 +88,7 @@ To add your own, create a file `~/.patman` like this::
+ Patman will also look for a `.patman` configuration file at the root
+ of the current project git repository, which makes it possible to
+ override the `project` settings variable or anything else in a
+-project-specific way. The values of this "local" configuration file
++project-specific way. The values of this "local" configuration file
+ take precedence over those of the "global" one.
+
+ Aliases are recursive.
+diff --git a/tools/patman/test_settings.py b/tools/patman/test_settings.py
+index 9c14b4aaa3..c768a2fc64 100644
+--- a/tools/patman/test_settings.py
++++ b/tools/patman/test_settings.py
+@@ -6,38 +6,62 @@
+ import argparse
+ import contextlib
+ import os
+-import subprocess
++import sys
+ import tempfile
+
+ from patman import settings
++from patman import tools
+
+
+ @contextlib.contextmanager
+ def empty_git_repository():
+ with tempfile.TemporaryDirectory() as tmpdir:
+ os.chdir(tmpdir)
+- subprocess.check_call(['git', 'init'])
++ tools.run('git', 'init', raise_on_error=True)
+ yield tmpdir
+
+
++@contextlib.contextmanager
++def cleared_command_line_args():
++ old_value = sys.argv[:]
++ sys.argv = [sys.argv[0]]
++ try:
++ yield
++ finally:
++ sys.argv = old_value
++
++
+ def test_git_local_config():
+- with empty_git_repository():
+- with tempfile.NamedTemporaryFile() as global_config:
+- global_config.write(b'[settings]\n'
+- b'project=u-boot\n')
+- global_config.flush()
+- parser = argparse.ArgumentParser()
+- parser.add_argument('-p', '--project', default='unknown')
+-
+- # Test "global" config is used.
+- settings.Setup(parser, 'unknown', global_config.name)
+- args, _ = parser.parse_known_args()
+- assert args.project == 'u-boot'
+-
+- # Test local config can shadow it.
+- with open('.patman', 'w', buffering=1) as f:
+- f.write('[settings]\n'
+- 'project=guix-patches\n')
+- settings.Setup(parser, 'unknown', global_config.name)
+- args, _ = parser.parse_known_args([])
+- assert args.project == 'guix-patches'
++ # Clearing the command line arguments is required, otherwise
++ # arguments passed to the test running such as in 'pytest -k
++ # filter' would be processed by _UpdateDefaults and fail.
++ with cleared_command_line_args():
++ with empty_git_repository():
++ with tempfile.NamedTemporaryFile() as global_config:
++ global_config.write(b'[settings]\n'
++ b'project=u-boot\n')
++ global_config.flush()
++ parser = argparse.ArgumentParser()
++ parser.add_argument('-p', '--project', default='unknown')
++ subparsers = parser.add_subparsers(dest='cmd')
++ send = subparsers.add_parser('send')
++ send.add_argument('--no-check', action='store_false',
++ dest='check_patch', default=True)
++
++ # Test "global" config is used.
++ settings.Setup(parser, 'unknown', global_config.name)
++ args, _ = parser.parse_known_args([])
++ assert args.project == 'u-boot'
++ send_args, _ = send.parse_known_args([])
++ assert send_args.check_patch
++
++ # Test local config can shadow it.
++ with open('.patman', 'w', buffering=1) as f:
++ f.write('[settings]\n'
++ 'project: guix-patches\n'
++ 'check_patch: False\n')
++ settings.Setup(parser, 'unknown', global_config.name)
++ args, _ = parser.parse_known_args([])
++ assert args.project == 'guix-patches'
++ send_args, _ = send.parse_known_args([])
++ assert not send_args.check_patch
diff --git a/gnu/packages/patches/u-boot-patman-local-conf.patch b/gnu/packages/patches/u-boot-patman-local-conf.patch
new file mode 100644
index 0000000000..3400982356
--- /dev/null
+++ b/gnu/packages/patches/u-boot-patman-local-conf.patch
@@ -0,0 +1,176 @@
+Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333354
+
+diff --git a/tools/patman/main.py b/tools/patman/main.py
+index bf300c6e64..3616b28f27 100755
+--- a/tools/patman/main.py
++++ b/tools/patman/main.py
+@@ -116,7 +116,7 @@ status.add_argument('-f', '--force', action='store_true',
+ argv = sys.argv[1:]
+ args, rest = parser.parse_known_args(argv)
+ if hasattr(args, 'project'):
+- settings.Setup(gitutil, parser, args.project, '')
++ settings.Setup(parser, args.project)
+ args, rest = parser.parse_known_args(argv)
+
+ # If we have a command, it is safe to parse all arguments
+diff --git a/tools/patman/patman.rst b/tools/patman/patman.rst
+index 8c5c9cc2cc..7828899879 100644
+--- a/tools/patman/patman.rst
++++ b/tools/patman/patman.rst
+@@ -74,7 +74,7 @@ out where to send patches pretty well.
+ During the first run patman creates a config file for you by taking the default
+ user name and email address from the global .gitconfig file.
+
+-To add your own, create a file ~/.patman like this::
++To add your own, create a file `~/.patman` like this::
+
+ # patman alias file
+
+@@ -85,6 +85,12 @@ To add your own, create a file ~/.patman like this::
+ wolfgang: Wolfgang Denk <wd@denx.de>
+ others: Mike Frysinger <vapier@gentoo.org>, Fred Bloggs <f.bloggs@napier.net>
+
++Patman will also look for a `.patman` configuration file at the root
++of the current project git repository, which makes it possible to
++override the `project` settings variable or anything else in a
++project-specific way. The values of this "local" configuration file
++take precedence over those of the "global" one.
++
+ Aliases are recursive.
+
+ The checkpatch.pl in the U-Boot tools/ subdirectory will be located and
+diff --git a/tools/patman/settings.py b/tools/patman/settings.py
+index 903d6fcb0b..e8e2908f1f 100644
+--- a/tools/patman/settings.py
++++ b/tools/patman/settings.py
+@@ -1,5 +1,6 @@
+ # SPDX-License-Identifier: GPL-2.0+
+ # Copyright (c) 2011 The Chromium OS Authors.
++# Copyright (c) 2022 Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
+ #
+
+ try:
+@@ -11,8 +12,7 @@ import argparse
+ import os
+ import re
+
+-from patman import command
+-from patman import tools
++from patman import gitutil
+
+ """Default settings per-project.
+
+@@ -190,7 +190,8 @@ def ReadGitAliases(fname):
+
+ fd.close()
+
+-def CreatePatmanConfigFile(gitutil, config_fname):
++
++def CreatePatmanConfigFile(config_fname):
+ """Creates a config file under $(HOME)/.patman if it can't find one.
+
+ Args:
+@@ -328,26 +329,46 @@ def GetItems(config, section):
+ except:
+ raise
+
+-def Setup(gitutil, parser, project_name, config_fname=''):
++def Setup(parser, project_name, config_fname=None):
+ """Set up the settings module by reading config files.
+
++ Unless `config_fname` is specified, a `.patman` config file local
++ to the git repository is consulted, followed by the global
++ `$HOME/.patman`. If none exists, the later is created. Values
++ defined in the local config file take precedence over those
++ defined in the global one.
++
+ Args:
+- parser: The parser to update
++ parser: The parser to update.
+ project_name: Name of project that we're working on; we'll look
+ for sections named "project_section" as well.
+- config_fname: Config filename to read ('' for default)
++ config_fname: Config filename to read. An error is raised if it
++ does not exist.
+ """
+ # First read the git alias file if available
+ _ReadAliasFile('doc/git-mailrc')
+ config = _ProjectConfigParser(project_name)
+- if config_fname == '':
++
++ if config_fname and not os.path.exists(config_fname):
++ raise Exception(f'provided {config_fname} does not exist')
++
++ if not config_fname:
+ config_fname = '%s/.patman' % os.getenv('HOME')
++ has_config = os.path.exists(config_fname)
++
++ git_local_config_fname = os.path.join(gitutil.get_top_level(), '.patman')
++ has_git_local_config = os.path.exists(git_local_config_fname)
+
+- if not os.path.exists(config_fname):
+- print("No config file found ~/.patman\nCreating one...\n")
+- CreatePatmanConfigFile(gitutil, config_fname)
++ # Read the git local config last, so that its values override
++ # those of the global config, if any.
++ if has_config:
++ config.read(config_fname)
++ if has_git_local_config:
++ config.read(git_local_config_fname)
+
+- config.read(config_fname)
++ if not (has_config or has_git_local_config):
++ print("No config file found.\nCreating ~/.patman...\n")
++ CreatePatmanConfigFile(config_fname)
+
+ for name, value in GetItems(config, 'alias'):
+ alias[name] = value.split(',')
+diff --git a/tools/patman/test_settings.py b/tools/patman/test_settings.py
+new file mode 100644
+index 0000000000..9c14b4aaa3
+--- /dev/null
++++ b/tools/patman/test_settings.py
+@@ -0,0 +1,43 @@
++# SPDX-License-Identifier: GPL-2.0+
++#
++# Copyright (c) 2022 Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
++#
++
++import argparse
++import contextlib
++import os
++import subprocess
++import tempfile
++
++from patman import settings
++
++
++@contextlib.contextmanager
++def empty_git_repository():
++ with tempfile.TemporaryDirectory() as tmpdir:
++ os.chdir(tmpdir)
++ subprocess.check_call(['git', 'init'])
++ yield tmpdir
++
++
++def test_git_local_config():
++ with empty_git_repository():
++ with tempfile.NamedTemporaryFile() as global_config:
++ global_config.write(b'[settings]\n'
++ b'project=u-boot\n')
++ global_config.flush()
++ parser = argparse.ArgumentParser()
++ parser.add_argument('-p', '--project', default='unknown')
++
++ # Test "global" config is used.
++ settings.Setup(parser, 'unknown', global_config.name)
++ args, _ = parser.parse_known_args()
++ assert args.project == 'u-boot'
++
++ # Test local config can shadow it.
++ with open('.patman', 'w', buffering=1) as f:
++ f.write('[settings]\n'
++ 'project=guix-patches\n')
++ settings.Setup(parser, 'unknown', global_config.name)
++ args, _ = parser.parse_known_args([])
++ assert args.project == 'guix-patches'