summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bf29f4d4b0..85105ce00a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31635,6 +31635,24 @@ GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
versa. Extended WKB/WKT are also supported.")
(license license:asl2.0)))
+(define-public python-cogapp
+ (package
+ (name "python-cogapp")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cogapp" version))
+ (sha256
+ (base32
+ "1c0xx3p3lzrlyqhmccyq9c50f8v9pqk2992gb4nl50h2yy1m3s8v"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://nedbatchelder.com/code/cog")
+ (synopsis "Content generation tool that leverages Python")
+ (description "Cog is a file generation tool. It allows using pieces of
+Python code as generators in your source files to generate arbitrary text.")
+ (license license:expat)))
+
(define-public python-bsdiff4
(package
(name "python-bsdiff4")