summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 54ea0caac3..ea439b7ac3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10578,6 +10578,31 @@ useful as a validator for JSON data.")
(define-public python2-validictory
(package-with-python2 python-validictory))
+(define-public python-pyelftools
+ (package
+ (name "python-pyelftools")
+ (version "0.25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyelftools" version))
+ (sha256
+ (base32
+ "090vdksbz341f7ljvr0zswblw4lspa8qaiikzyjkf318arpxmil9"))))
+ (build-system python-build-system)
+ ;; Test suite requires python-setuptools
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page
+ "https://github.com/eliben/pyelftools")
+ (synopsis
+ "Analyze binary and library file information")
+ (description "This Python library provides interfaces for parsing and
+analyzing two binary and library file formats; the Executable and Linking
+Format (ELF), and debugging information in the Debugging With Attributed
+Record Format (DWARF).")
+ (license license:public-domain)))
+
(define-public python-pyev
(package
(name "python-pyev")