summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab4102273a..0ef71605e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1863,7 +1863,17 @@ Python 3 support.")
;; FIXME: Tests require pytest, which itself relies on setuptools.
;; One could bootstrap with an internal untested setuptools.
(arguments
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'compatibility-fixes
+ (lambda _
+ ;; HTMLParser no longer exists.
+ (substitute* "setuptools/py33compat.py"
+ (("html_parser.HTMLParser\\(\\).unescape")
+ "html.unescape"))
+ ;; This needs distutils.msvc9compiler
+ (delete-file "setuptools/tests/test_msvc.py"))))))
(native-inputs
(list unzip))
(home-page "https://pypi.org/project/setuptools/")