summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm61
1 files changed, 34 insertions, 27 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 851bda3c2d..0290965a36 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5394,37 +5394,44 @@ use this package to insert PostScript files, in addition to PDF files.")
(license license:lppl1.3+)))
(define-public texlive-stmaryrd
- (package
- (name "texlive-stmaryrd")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "fonts" "stmaryrd"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "08pn4ca3vl6qm9l3wm5h5iyjsrg411kkm1yana329xwg2j14s9n6"))))
- (build-system texlive-build-system)
- (arguments
- '(#:tex-directory "latex/stmaryrd"
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'patch-ins
- (lambda _
- (substitute* "stmaryrd.ins"
- (("^%% LaTeX2e.*") "\\input docstrip\n")
- (("fontdef\\}\\}" line)
- (string-append line "\n\\endbatchfile")))
- #t)))))
- (home-page "https://www.ctan.org/pkg/stmaryrd")
- (synopsis "St Mary Road symbols for theoretical computer science")
- (description
- "The fonts were originally distributed as Metafont sources only, but
+ (let ((template (simple-texlive-package
+ "texlive-stmaryrd"
+ (list "/fonts/afm/public/stmaryrd/"
+ "/fonts/map/dvips/stmaryrd/"
+ "/fonts/source/public/stmaryrd/"
+ "/fonts/tfm/public/stmaryrd/"
+ "/fonts/type1/public/stmaryrd/"
+ "/source/fonts/stmaryrd/"
+ "/doc/fonts/stmaryrd/")
+ (base32
+ "0yn0yl6x1z9ab5gb56lhvkqabd2agz3ggxifwxkiysrj5780j29z"))))
+ (package
+ (inherit template)
+ (arguments (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/stmaryrd")
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/fonts/stmaryrd")
+ #t))
+ (add-after 'chdir 'patch-ins
+ (lambda _
+ (substitute* "stmaryrd.ins"
+ (("^%% LaTeX2e.*") "\\input docstrip\n")
+ (("fontdef\\}\\}" line)
+ (string-append line "\n\\endbatchfile")))
+ #t))))))
+ (home-page "https://www.ctan.org/pkg/stmaryrd")
+ (synopsis "St Mary Road symbols for theoretical computer science")
+ (description
+ "The fonts were originally distributed as Metafont sources only, but
Adobe Type 1 versions are also now available. Macro support is provided for
use under LaTeX; the package supports the @code{only} option (provided by the
@code{somedefs} package) to restrict what is loaded, for those who don't need
the whole font.")
- (license license:lppl)))
+ (license license:lppl))))
(define-public texlive-fonts-stmaryrd
(deprecated-package "texlive-fonts-stmaryrd" texlive-stmaryrd))