summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index caae27b0f9..6196d6bd69 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -452,26 +452,20 @@ available, greatly increasing its breadth and scope.")
(substitute* (string-append out "/lib/R/bin/libtool")
(((string-append
"(-L)?("
- (assoc-ref inputs "bzip2")
- "|"
- (assoc-ref inputs "perl")
- "|"
- (assoc-ref inputs "texlive-bin")
- "|"
- (assoc-ref inputs "texinfo")
- "|"
- (assoc-ref inputs "xz")
- "|"
(format #false
"~a/[^-]+-(~{~a~^|~})-[^/]+"
(%store-directory)
- '("glibc-utf8-locales"
+ '("bzip2"
+ "file"
+ "glibc-utf8-locales"
+ "graphite2"
"libselinux"
"libsepol"
- "file"
+ "perl"
+ "texinfo"
"texlive-bin"
"util-macros"
- "graphite2"))
+ "xz"))
"|"
(format #false "~a/[^-]+-glibc-[^-]+-static"
(%store-directory))