summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc76c67d58..27c5249bed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22920,7 +22920,7 @@ according to a parsing expression grammar.")
(define-public emacs-eldev
(package
(name "emacs-eldev")
- (version "1.6")
+ (version "1.7")
(source
(origin
(method git-fetch)
@@ -22929,7 +22929,7 @@ according to a parsing expression grammar.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0m2d607hprkl1pdapxsfjwag7plf822ig59qb6jjzy9m7gwg21k5"))))
+ (base32 "1q30r6di3r8dxxfbxfyii7kfvjj83c16bxx8ixadki3ix6imd6l5"))))
(build-system emacs-build-system)
(arguments
(list
@@ -22942,12 +22942,9 @@ according to a parsing expression grammar.")
(setenv "ELDEV_LOCAL" (getcwd))
(make-file-writable "test/project-i/project-i-autoloads.el")))
(add-after 'unpack 'skip-failing-tests
- ;; FIXME: 3 tests are failing. Skip them for now.
+ ;; FIXME: 2 tests are failing. Skip them for now.
(lambda _
- (delete-file "test/upgrade-self.el")
- (substitute* "test/doctor.el"
- (("\\(ert-deftest eldev-doctor-up-to-date-copyright-2 .*" all)
- (string-append all "(skip-unless nil)\n")))))
+ (delete-file "test/upgrade-self.el")))
(add-after 'install 'install-eldev-executable
;; This constructs the eldev executable from templates and
;; installs it in the specified directory.