summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/c.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 113a331070..39f048e993 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -197,8 +197,9 @@ standard.")
(substitute* (list "cc/ccom/scan.l" "cc/cxxcom/scan.l")
(("lineno, ") ""))))
(replace 'check
- (lambda _
- (invoke "make" "-C" "cc/cpp" "test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "-C" "cc/cpp" "test")))))))
(native-inputs (list bison flex))
(synopsis "Portable C compiler")
(description