summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:10:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:37:01 +0200
commit5a8b23185d3ad4ae4f4a07807447cc5b598a0322 (patch)
treef1586da52d786c661c0cc4f19c0892819f59875f
parent272cfdffba638e43ed11700e1b8106b8c8ef2e1c (diff)
gnu: Add texlive-xcjk2uni.
* gnu/packages/tex.scm (texlive-xcjk2uni): New variable.
-rw-r--r--gnu/packages/tex.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7b331a9873..2999084f02 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22945,6 +22945,51 @@ for the user.")
(define-deprecated-package texlive-latex-hycolor texlive-hycolor)
+(define-public texlive-xcjk2uni
+ (package
+ (name "texlive-xcjk2uni")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xcjk2uni/"
+ "source/latex/xcjk2uni/"
+ "tex/latex/xcjk2uni/")
+ (base32
+ "1vjp47ngrirrvbnk4vnm5lbysj3qlbwxbfc1szc22gaikm52ggaq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'copy-ctxdocstrip.tex
+ ;; There's a circular dependency between this package (where
+ ;; `ctex' should be a native input) and `ctex' (where this package
+ ;; is a propagated input). To work around this, install the
+ ;; specific "ctxdocstrip.tex" file from `ctex' in the build
+ ;; directory and set TEXINPUTS variable accordingly so the process
+ ;; can find it.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (install-file (search-input-file inputs
+ "tex/generic/ctex/ctxdocstrip.tex")
+ "build/")
+ (setenv "TEXINPUTS" (string-append (getcwd) "/build:")))))))
+ (native-inputs
+ (list (texlive-origin
+ "ctxdocstrip.tex" (number->string %texlive-revision)
+ (list "tex/generic/ctex/ctxdocstrip.tex")
+ (base32
+ "154v2d6wfzhfg654nlh2apy9zr78d09rkimymyjqpxymkpbk8lli"))))
+ (home-page "https://ctan.org/pkg/xcjk2uni")
+ (synopsis "Convert CJK characters to Unicode, in pdfTeX")
+ (description
+ "The package provides commands to convert CJK characters to Unicode in
+non-UTF-8 encoding; it provides hooks to support hyperref in producing correct
+bookmarks. The bundle also provides @code{/ToUnicode} mapping file(s) for
+a CJK subfont; these can be used with the cmap package, allowing searches of,
+and cut-and-paste operations on a PDF file generated by pdfTeX.")
+ (license license:lppl1.3c)))
+
(define-public texlive-xcolor
(package
(name "texlive-xcolor")