summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:28:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:22 +0200
commit1775708fa604475169a00be336b2c58ab387cea3 (patch)
tree820bf8cfe05788137223927c2cfe789892980de1 /gnu/packages
parent905d8997cd3c52277ed627c945ef6a6ec57ef8ca (diff)
gnu: Add texlive-diadia.
* gnu/packages/tex.scm (texlive-diadia): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 848f828d30..bf3a2fcc0f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4935,6 +4935,33 @@ custom derivatives and differential operators. The options follow
a consistent naming scheme making them easy to use and understand.")
(license license:lppl1.3+)))
+(define-public texlive-diadia
+ (package
+ (name "texlive-diadia")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/diadia/" "scripts/diadia/"
+ "tex/latex/diadia/")
+ (base32
+ "1sjnjabgqsv6v45sffkkzm78fnx89vmk836dajsvck5pd5nvkzxv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "diadia.lua")))
+ (home-page "https://ctan.org/pkg/diadia")
+ (synopsis "Package to keep a diabetes diary")
+ (description
+ "The @code{diadia} package allows you to keep a diabetes diary. Usually,
+this means keeping record of certain medical values like blood sugar, blood
+pressure, pulse or weight. It might also include other medical,
+pharmaceutical or nutritional data (HbA1c, insulin doses, carbohydrate units).
+
+The @code{diadia} package supports all of this plus more --- simply by adding
+more columns to the data file! It is able to evaluate the data file and
+typesets formatted tables and derived plots. Furthermore, it supports
+medication charts and info boxes.")
+ (license license:lppl)))
+
(define-public texlive-diagbox
(package
(name "texlive-diagbox")