summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 19:27:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 20:25:22 +0200
commit905d8997cd3c52277ed627c945ef6a6ec57ef8ca (patch)
treecc3fc55a238301178fc80452962a23729944d2e4 /gnu/packages
parent1db3f1bacba267b03566ce01a2d3b827b4f15150 (diff)
gnu: Add texlive-covington.
* gnu/packages/tex.scm (texlive-covington): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 10cdb0af1e..848f828d30 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4645,6 +4645,26 @@ files created by pLaTeX or upLaTeX, using @code{hyperref}.")
mathematical environments.")
(license license:bsd-2)))
+(define-public texlive-covington
+ (package
+ (name "texlive-covington")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/covington/"
+ "tex/latex/covington/")
+ (base32
+ "0h47zgbiylnirwcjprh31q2n8g842qlhlddd733xn1zal3n5alsz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/covington")
+ (synopsis "LaTeX macros for Linguistics")
+ (description
+ "This package provides numerous minor LaTeX enhancements for linguistics,
+including multiple accents on the same letter, interline glosses (word-by-word
+translations), Discourse Representation Structures, and example numbering.")
+ (license license:lppl1.3+)))
+
(define-public texlive-crossrefenum
(package
(name "texlive-crossrefenum")