summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 19:24:50 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:33 +0200
commit2ebc4f361b962e9c879cfacfd577a5cc1ee99390 (patch)
tree369543622ccc4e5df7d587e99ede8675be963c43 /gnu/packages
parent6f4595533a3d012baefc583886e3402f909efd1a (diff)
gnu: Add rust-unchecked-index-0.2.
* gnu/packages/crates-io.scm (rust-unchecked-index-0.2): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index caf514068e..0dfe93f8f4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7394,6 +7394,27 @@ with the Unicode character database.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-unchecked-index-0.2
+ (package
+ (name "rust-unchecked-index")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "unchecked-index" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0p6qcai1mjayx59cpgk27d0zgw9hz9r1ira5jiqil66f4ba8dfpf"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/bluss/unchecked-index")
+ (synopsis "Unchecked indexing wrapper using regular index syntax")
+ (description
+ "Unchecked indexing wrapper using regular index syntax.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-unicase-2.4
(package
(name "rust-unicase")