summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-08 11:37:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-08 11:53:29 +0200
commite118b92cfe7a598b71dbbda2622b7551f4a72104 (patch)
tree51c2e9008d44afa00a7ef07ec7c7f4d98372f5c8 /gnu/packages
parentc2a2d40e6d9f0cac3ae9496a6a1b5fb15346b947 (diff)
gnu: Add r-seurat5.
* gnu/packages/cran.scm (r-seurat5): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 53cab3adad..e5a6c806b4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -34415,6 +34415,74 @@ algorithms; density clustering, hierarchical clustering, k-means, and the
discovery of differentially expressed genes and markers.")
(license license:gpl3)))
+;; Seurat5 is only available via the seurat5 branch. It will replace r-seurat
+;; eventually once it has been released to CRAN.
+(define-public r-seurat5
+ (let ((commit "9d59c02042b9ae4f182fbde84cc8b18c0873ef4d")
+ (revision "1"))
+ (package
+ (inherit r-seurat)
+ (name "r-seurat5")
+ (version (git-version "4.9.9.9044" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/satijalab/seurat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y4wl6aanq9scn2clazlxsar35g64v4sfy561j43fq1i85na7m4i"))))
+ (propagated-inputs (list r-cluster
+ r-cowplot
+ r-fastdummies
+ r-fitdistrplus
+ r-future
+ r-future-apply
+ r-generics
+ r-ggplot2
+ r-ggrepel
+ r-ggridges
+ r-httr
+ r-ica
+ r-igraph
+ r-irlba
+ r-jsonlite
+ r-kernsmooth
+ r-leiden
+ r-lifecycle
+ r-lmtest
+ r-mass
+ r-matrix
+ r-matrixstats
+ r-miniui
+ r-patchwork
+ r-pbapply
+ r-plotly
+ r-png
+ r-progressr
+ r-rann
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppannoy
+ r-rcppeigen
+ r-rcpphnsw
+ r-rcppprogress
+ r-reticulate
+ r-rlang
+ r-rocr
+ r-rspectra
+ r-rtsne
+ r-scales
+ r-scattermore
+ r-sctransform
+ r-seurat5object
+ r-shiny
+ r-spatstat-explore
+ r-spatstat-geom
+ r-tibble
+ r-uwot)))))
+
(define-public r-seuratdisk
(let ((commit "163f1aade5bac38ed1e9e9c912283a7e74781610")
(revision "1"))