summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:06 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:26 +0200
commite5fdf051c9ef3d54ca7f81249a8efd3c4ea1c578 (patch)
tree528dee75dca7aa869756e634e680632758b21eec /gnu/packages
parent9528b8993540865c941fe463d44ce5028463310b (diff)
gnu: Add trytond-account-payment.
* gnu/packages/tryton.scm (trytond-account-payment): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 0e91b8d864..db7f46f019 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -779,6 +779,33 @@ average price of the posted invoice lines that are linked to it.")
(deprecated-package
"python-trytond-account-invoice-stock" trytond-account-invoice-stock))
+(define-public trytond-account-payment
+ (package
+ (name "trytond-account-payment")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_payment" version))
+ (sha256
+ (base32 "006d78kcml65mxikqp80igln118vkxfs9ah03lq5j9bvnfr6bb2m"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_payment"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-account-invoice" ,trytond-account-invoice)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-company" ,trytond-company)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-party" ,trytond-party)))
+ (home-page "https://docs.tryton.org/projects/modules-account-payment")
+ (synopsis "Tryton module for payment")
+ (description "This package provides a Tryton module for generating grouped
+payments for receivable or payable Account Move Lines.")
+ (license license:gpl3+)))
+
(define-public trytond-account-product
(package
(name "trytond-account-product")