summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:17:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:38 +0200
commit4f802695146082ee1e6065201fd144f49a0c6d83 (patch)
tree4d165a18f28dcc516864fddc2e880557ede5f915 /gnu
parentbac5097052326660735bdb6613fdf268c9b6c7bc (diff)
gnu: Add texlive-match-parens.
* gnu/packages/tex.scm (texlive-match-parens): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8c5b800d54..a5b2fac38d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2842,6 +2842,31 @@ environments and another with all extracted environments converted to
without HarfBuzz.")
(license license:gpl2)))
+(define-public texlive-match-parens
+ (package
+ (name "texlive-match-parens")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/match_parens/"
+ "scripts/match_parens/")
+ (base32
+ "0qqxbh3h1xkggs5p2gnis4z8h3s0mwknszyjzs2fslnq16yyqi27")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "match_parens")))
+ (inputs (list ruby))
+ (home-page "https://ctan.org/pkg/match_parens")
+ (synopsis
+ "Find mismatches of parentheses, braces, (angle) brackets, in texts")
+ (description
+ "Mismatches of parentheses, braces, (angle) brackets, especially in TeX
+sources which may be rich in those, may be difficult to trace. This little
+Ruby script helps you by writing your text to standard output, after adding
+a left margin to your text, which will normally be almost empty, but will
+clearly show any mismatches.")
+ (license license:gpl3+)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")